Simulateur de vol google earth - la plaie !

Vous avez un didactiel ou une astuce particulière concernant un logiciel, partagez votre expérience dans cette partie.
Avatar de l’utilisateur
le Manchot Masqué
Administrateur du site
Messages : 419
Inscription : lun. 26 mai 2008, 21:05
Distribution : Debian, Ubuntu
Niveau : Moitié plein !
Localisation : Guebwiller

Simulateur de vol google earth - la plaie !

Message par le Manchot Masqué » jeu. 13 août 2015, 23:23

Oui, je sais : c'est MAL que de parler d'une expérience vécue sur un logiciel privateur de liberté... Mais ce genre d'expérience permet aussi de "mesurer" les évolutions de notre OS en terme de facilité d'usage grand public. Autant les logiciels courants ne sont plus un problème aujourd'hui, autant il faut être réaliste : nombre de gens, et souvent des jeunes, gardent encore un windows en à côté pour les jeux. L'arrivée de Steam a été une excellente nouvelle, mais il faudra sûrement du temps pour changer les habitudes, même si les éditeurs semblent de plus en plus conscients que les joueurs GNU/Linux ont aussi des sous en poche à dépenser, ce qui est une très bonne chose !

Pour ma part, mon but ici était de faire du simulateur de vol dans Google Earth. J'y étais arrivé il y a quelques années, et je voulais savoir si les choses avaient évolué... Ce qui suit est donc mon expérience perso.
Matériel : ATI Radeon HD4670 (RV730) sur mon vieux Q6600 boosté au SSD (plus réactif que bon nombre de machines actuelles - ça fait toujours rire de penser à ceux qui râlent sous windows parce que leur machine se traîne...).
Distribution choisie : il faut absolument rester en Ubuntu 12.04 LTS pour la bonne et simple raison qu'ATI ne fait plus de support pour les cartes graphiques de la série HD2xxx à HD4xxx, et ce depuis le passage de Xorg de 1.12 à 1.13 ("nous ne sommes pas de ceux qui diront que", mais cela ressemble quand même beaucoup à de l'obsolescence programmée, non ?!).
J'ai donc pris la 12.04.2 LTS 64 bits en iso pour mon installation, et bloqué la version d'XOrg via synaptic, histoire d'être tranquille. J'ai hésité à prendre la 12.04.5 tout de suite, car de mémoire, Canonical avait déjà fait le changement de X vers la version 1.13, lequel pose ensuite problème. Pour ceux qui ne le savent pas, on peut "bloquer" des paquets quand des versions récentes posent problème, ce qui est fort heureusement assez rare...
Installation de mesa-utils : performances décevantes de la carte aux alentours des 60fps avec glxgears... Essai d'installation du paquet fglrx (accélération pour les ATI/AMD) inclus dans la distribution : aucune amélioration.
Il faut en fait utiliser un ppa particulier de fglrx : https://launchpad.net/~makson96/+archive/ubuntu/fglrx et là, o miracle, on passe aux alentours des 4500 fps - plutôt cool !
On arrive à google earth : installation de la version 64 bits : catastrophe : le logiciel commence à démarrer, et plante au bout de 2s...
Après plusieurs recherches, il faut se rendre à l'évidence : la version 64 bits est bugée à mort ! Il faut donc prendre la version 32 bits et installer le paquet ia32-libs pour ajouter les librairies en 32 bits... Ouf : ça démarre !
Connexion du joystick : un Saitek Cyborg un peu âgé, mais encore tout à fait correct. Pas reconnu pour le moment, malgré le fait que le paquet jstest-gtk me reconnaît la manette et tous les boutons sans aucun problème ! Pourquoi notre cher ami google est-il donc incapable de prendre en charge une manette, pourtant parfaitement reconnue sous l'OS libre ? Grand mystère... Mais si vous avez la réponse, n'hésitez pas ! ;)

Tout cela pour dire au final qu'entre la mauvaise volonté d'AMD de maintenir ses drivers, des choix de Canonical pas toujours judicieux, le manque de sérieux de google (pourquoi proposer du 64 bits s'il n'est pas correctement finalisé ?), il est très difficile de faire du simulateur de vol dans google earth actuellement avec du matériel un peu ancien !

Maintenant si vous avez des retours avec du matériel plus récent, n'hésitez pas à les partager ici !

Avatar de l’utilisateur
le Manchot Masqué
Administrateur du site
Messages : 419
Inscription : lun. 26 mai 2008, 21:05
Distribution : Debian, Ubuntu
Niveau : Moitié plein !
Localisation : Guebwiller

Re: Simulateur de vol google earth - la plaie !

Message par le Manchot Masqué » ven. 14 août 2015, 14:30

Encore une précision amusante : XPlane m'a reconnu immédiatement toute la manette et tous les boutons sans aucun problème !
Le problème est donc bien du côté de google. Chacun en tirera ses conclusions...

Avatar de l’utilisateur
le Manchot Masqué
Administrateur du site
Messages : 419
Inscription : lun. 26 mai 2008, 21:05
Distribution : Debian, Ubuntu
Niveau : Moitié plein !
Localisation : Guebwiller

Re: Simulateur de vol google earth - la plaie !

Message par le Manchot Masqué » dim. 24 nov. 2019, 21:05

2019 - plus cocasse encore : avec un vieil imac de 2009 réinstallé sous Ubuntu 18.04 LTS, et la même manette Cyborg EVO, le joystick est RECONNU sous google earth, mais toujours pas sur un PC assemblé, avec pourtant la même distribution GNU/Linux !

C'est là où l'on mesure tout le FOUTAGE DE GUEULE monstrueux de gogol, car rappelons que l'imac sous Core2Duo (intel) n'est toujours qu'un PC classique, relooké par apple et vendu 2x son prix... Il n'y a donc aucune raison technique pouvant justifier cette différence flagrante de reconnaissance entre les 2 PCs, sinon une volonté délibérée de la firme de snober les libristes aux détriment des OS privateurs de liberté.

Une fois de plus, google démontre clairement sa nocivité évidente, face à l'informatique libre que nous défendons. A bon entendeur !

Répondre