Problème de montage de partition

Venez nous en parler, c'est ici que l'on vous conseillera !
jeanlou19
Messages : 37
Inscription : mar. 27 mai 2008, 18:11
Distribution : Ubuntu Hardy Heron
Niveau : Débutant
Localisation : Mulhouse
Contact :

Problème de montage de partition

Message par jeanlou19 » ven. 06 juin 2008, 17:03

Quand on se retrouve avec ce message-ci, comment faire pour en sortir :

mount: wrong fs type, bad option, bad superblock on /dev/sda12,
missing codepage or helper program, or other error
Dans quelques cas certaines informations sont utiles dans syslog - essayez
dmesg | tail ou quelque chose du genre
??
Quelles solutions et quelles sont les étapes vers ces solutions ?

Avatar de l’utilisateur
le Manchot Masqué
Administrateur du site
Messages : 439
Inscription : lun. 26 mai 2008, 21:05
Distribution : Debian, Ubuntu
Niveau : Moitié plein !
Localisation : Guebwiller

Re: Problème de montage de partition

Message par le Manchot Masqué » ven. 06 juin 2008, 22:38

L'erreur specifie que tu n'utilises pas le bon systeme de fichier ou que celui que tu indiques ne colle pas avec la realite...

C'est un peu surprenant dans le sens ou les monteurs de Gnome et KDE sont aujourd'hui au point dans ce domaine.
Peut etre un reste d'une ancienne configuration dans /etc/fstab ??? En tout cas, il vaut mieux tester en ligne de commande.

Code : Tout sélectionner

fdisk -l /dev/sda 
pour avoir le liste des partitions du systeme et surtout le type exact de partitions. Le sda est a modifier bien entendu avec le peripherique que tu veux tester.

Ensuite

Code : Tout sélectionner

mount -t vfat /dev/sda1 /media/usb0
Ce qui importe ici c'est l'option -t avec le type de fichier qui suit ; ici on monte la premiere partition du premier disque qui est de type FAT32 dans le repertoire /media/usb0/.

Oui mais quels sont les systemes de fichiers supportes :?:

Suivant la distribution, on a une liste plus ou moins exacte des systemes de fichiers supportes avec

Code : Tout sélectionner

cat /proc/filesystems | grep -v nodev
Comme le kernel decharge les modules non utilises au bout d'un certain temps, la commande ne renvoie que les systemes actuellement utilises...

Pour avoir une liste plus exacte, il faut zieuter du cote des modules du noyau en cours d'utilisation avec :

Code : Tout sélectionner

ll  /lib/modules/`uname -r `/kernel/fs/
et c'est la qu'on se rend compte de la richesse de Linux face a certains OS proprietaires : il suffit de zieuter le nombre de filesystems supportes... :P

jeanlou19
Messages : 37
Inscription : mar. 27 mai 2008, 18:11
Distribution : Ubuntu Hardy Heron
Niveau : Débutant
Localisation : Mulhouse
Contact :

Re: Problème de montage de partition

Message par jeanlou19 » sam. 07 juin 2008, 12:41

Je n'ai pas pensé qu'il puisse y avoir confusion avec une "partition USB" ...
Il s'agit d'une partition sur un disque sata.
Je pense que la démarche est à peu prêt pareille.
La partition était cependant montée lors de son installation en ext3.
Ce n'est pas la première fois que le problème se pose mais jusqu'à présent, je n'ai pas pu retrouver l'accès à ces partitions.
Une partition qui a été créée en ext3 ne peut pas être montée en vfat, n'est-ce pas ?

Merci

Avatar de l’utilisateur
le Manchot Masqué
Administrateur du site
Messages : 439
Inscription : lun. 26 mai 2008, 21:05
Distribution : Debian, Ubuntu
Niveau : Moitié plein !
Localisation : Guebwiller

Re: Problème de montage de partition

Message par le Manchot Masqué » lun. 09 juin 2008, 08:21

Une cle USB peut etre partitionnee en ce que l'on veut : ext3, vfat, ...
Si on l'a creee en ext3, pas la peine d'essayer de la monter en vfat.
Normalement, la Ubuntu reconnait automatiquement le systeme de fichier et l'affiche proprement sans intervention de l'utilisateur, a moins bien entendu d'avoir trifouiller dans la config...

Gael
Messages : 40
Inscription : mer. 28 mai 2008, 20:16
Distribution : Gentoo
Niveau : Confirmé

Re: Problème de montage de partition

Message par Gael » mar. 10 juin 2008, 11:55

Avant de pouvoir répondre de façon pertinente, ce serait bien de savoir dans quelle conditions apparait le message !

Qui l'affiche, après quel évènement, quelle commande console éventuellement etc ...

jeanlou19
Messages : 37
Inscription : mar. 27 mai 2008, 18:11
Distribution : Ubuntu Hardy Heron
Niveau : Débutant
Localisation : Mulhouse
Contact :

Re: Problème de montage de partition

Message par jeanlou19 » ven. 20 juin 2008, 10:32

Gael a écrit :Avant de pouvoir répondre de façon pertinente, ce serait bien de savoir dans quelle conditions apparait le message !

Qui l'affiche, après quel évènement, quelle commande console éventuellement etc ...
Oui, c'est bien juste ...
Pour une des partitions, le message apparaît dès le lancement du système et fait même un blocage au lancement ... car la parttion en question se trouve sur le même disque que celui où se trouve le système.
...
Pour d'autres, c'est quand je tente de les monter...
...
Ce sont des partitions où une erreur s'est glissée je ne sais trop comment mais en tout cas, ces partitions ne sont plus accessibles ...
Ubuntu ne les reconnaît pas avec gparted mais le gestionnaire departition mandriva les voit comme des ext2 ??? ... mais sans pour autant arriver à vraiment les monter ...
...
Merci

Gael
Messages : 40
Inscription : mer. 28 mai 2008, 20:16
Distribution : Gentoo
Niveau : Confirmé

Re: Problème de montage de partition

Message par Gael » mer. 25 juin 2008, 17:00

Est-ce que ces partitions apparaissent dans /dev ?

Si tu fais un fdisk -l /dev/sda ça donne quoi ?

Répondre